AI Processing Delays

Incident Report for Medsender

Resolved

We saw elevated error rates for one of our AI models that affected a small subset of users, which meant they were seeing minor delays in their AI processing of their documents. The incident has since been resolved
Posted May 21, 2026 - 10:47 EDT

Investigating

Some customers may be experiencing delays for Medsender AI to process their documents. Our team is currently investigating the issue.
Posted May 21, 2026 - 10:28 EDT
This incident affected: Medsender AI.